Potential Upstream Banking issue

Incident Report for Uber Statuspage

Resolved

The issue has been resolved and no impact was detected.
Posted Nov 03, 2025 - 12:54 CST

Monitoring

One of Branch's banking partners is having technical issues. Branch customers are not currently impacted, but the situation is being watched closely.
Posted Nov 03, 2025 - 10:13 CST
This incident affected: Disbursements.