Incident with disbursements

Incident Report for Uber Statuspage

Resolved

This incident has been resolved.
Posted Mar 05, 2026 - 11:36 CST

Investigating

We are aware of an ongoing issue and we are investigating.
Posted Mar 05, 2026 - 11:25 CST
This incident affected: Disbursements.