Service Notice
Incident Report for Uber Statuspage
Resolved
This incident has been resolved.
Posted Jan 03, 2025 - 19:42 CST
Monitoring
Branch is working with our banking partner on resolving a delay in yesterday's ACH deposits and transfers. Today's deposits have processed. Disbursements processed through Pay Admin are not impacted at this time. Payments will be processed as soon as the issue is resolved, no action is needed at this time.
Posted Jan 03, 2025 - 12:50 CST
This incident affected: Disbursements.