Services unavailable

Incident Report for Uber Statuspage

Resolved

Issue was related to a DNS update. It has been resolved and services restored.
Posted Jul 08, 2025 - 10:36 CDT

Investigating

A number of services are unavailable. Branch's technical teams are actively engaged in troubleshooting.
Posted Jul 08, 2025 - 10:25 CDT
This incident affected: Pay Admin, Partner API, Wallet Creation, and Disbursements.