PayAdmin and Mobile Applications may be experiencing latency

Incident Report for Uber Statuspage

Resolved

This incident has been resolved.
Posted Sep 10, 2025 - 14:54 CDT

Monitoring

A fix has been implemented and the system health is being monitored closely.
Posted Sep 10, 2025 - 12:50 CDT

Identified

A potential root cause has been identified and solutions are being tested.
Posted Sep 10, 2025 - 11:34 CDT

Investigating

PayAdmin and Mobile Applications may be experiencing latency. Branch Engineers are investigating.
Posted Sep 10, 2025 - 09:24 CDT
This incident affected: Pay Admin and Partner API.